Navisworks |
Options which controls the Navisworks export.

System Object
Autodesk.Revit.DB NavisworksExportOptions
Autodesk.Revit.DB NavisworksExportOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The NavisworksExportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | NavisworksExportOptions | Create an instance of Navisworks Export Options set with default values. |

Name | Description | |
---|---|---|
![]() | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false. |
![]() | ConvertLights | True to convert lights, false otherwise. Default value is false. |
![]() | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true. |
![]() | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared. |
![]() | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true. |
![]() | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true. |
![]() | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false. |
![]() | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false. |
![]() | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true. |
![]() | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true. |
![]() | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model. |
![]() | ExportUrls | True to export URL parameters, false otherwise. Default value is true. |
![]() | FacetingFactor | Faceting factor. Default value is 1.0. |
![]() | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All. |
![]() | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the NavisworksExportOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetSelectedElementIds | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |