Conceptual |
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElementId GetRoofConstructionType(
Document ccda,
ConceptualConstructionRoofType typeEnum
)
Parameters
- ccda Document
- The Document.
- typeEnum ConceptualConstructionRoofType
- The ConceptualConstructionRoofType to get the ConceptualConstructionType for.
Return Value
ElementIdReturns ElementId of a ConceptualConstructionType.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionRoofType. -or- A value passed for an enumeration argument is not a member of that enumeration |