CurveOverlapPoint Class


Curve Overlap Point Class

A point of overlap of two curves and its type of overlap.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CurveOverlapPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CurveOverlapPoint : IDisposable

The CurveOverlapPoint type exposes the following members.

Properties
Name Description
Public property FirstParameter The point's unnormalized parameter on the first curve.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Point The 3D coordinate of the point.
Public property SecondParameter The point's unnormalized parameter on the second curve.
Public property Type The type of overlap at the point.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CurveOverlapPoint
Top
See Also