Create Method (Document, String, LoadCombinationType, LoadCombinationState)


Load Combination Create(Document, String, Load Combination Type, Load Combination State) Method

Creates a new LoadCombination.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static LoadCombination Create(
	Document document,
	string name,
	LoadCombinationType type,
	LoadCombinationState state
)

Parameters

document Document
The Document to which new load combination element will be added.
name String
The name of the load combination.
type LoadCombinationType
The type of the load combination.
state LoadCombinationState
The state of the load combination.

Return Value

LoadCombination
The newly created load combination element if successful, otherwise.
Exceptions
Exception Condition
ArgumentException The given name is not unique
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also