BuiltInFailures.ArrayFailures Class


Built In Failures Array Failures Class

Failures about Arrays.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ArrayFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ArrayFailures

The BuiltInFailures ArrayFailures type exposes the following members.

Properties
Name Description
Public property Static member ArrayingNotSupportedForElements Arraying is not currently supported for the selected elements.
Public property Static member ArrayMixedModAndViewSpecElemsCorruption Unable to array this mixture of modeling and view specific elements.
Public property Static member ArrayMixedModAndViewSpecElemsWarning You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
Public property Static member CannotCreateArraySelectionIsGrouped Can't create an array because the selection cannot be grouped.
Public property Static member ConstraintsNotSatisfied Constraints are not satisfied
Public property Static member CouldntFindNewHostsForElements Couldn't find new hosts for elements in array.
Public property Static member IdenticalGeometryCopiesInArray This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
Public property Static member RadiusTooSmall Radius is too small.
Top
See Also