Electrical |
Provides access to the Electrical Equipment in Autodesk Revit.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElectricalEquipment type exposes the following members.

Name | Description | |
---|---|---|
![]() | CircuitNamingSchemeId | The CircuitNamingSchemeId used in the Electrical Equipment. The CircuitNamingSchemeId is used to retrieve the circuit naming scheme id of the Electrical Equipment. |
![]() | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel ) |
![]() | DistributionSystem | get or set the Distribution System for the Electrical Equipment. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | IsSwitchboard | The electrical equipment is a switchboard or not. This property returns true if the electrical equipment is a switchboard. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPModel ) |
![]() | MaxNumberOfCircuits | The maximum number of circuits for switchboard. The quantity of circuits can be assigned to switchboard through breaker. |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel ) |
![]() | GetCircuitNamingSchemeType | Gets enumerated type of the circuit naming scheme used with Electrical Equipment. |
![]() | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidCircuitNamingSchemeId | Verifies that the circuit naming scheme id can be used with Electrical Equipment. |
![]() | IsValidDistributionSystem | Verifies that the Distribution System can be assigned to the Electrical Equipment. |
![]() | SetCircuitNamingSchemeType | Sets the circuit naming scheme for Electrical Equipment. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |