Electrical |
Provides access to the Electrical Equipment in Autodesk Revit.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB MEPModel
Autodesk.Revit.DB.Electrical ElectricalEquipment
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElectricalEquipment type exposes the following members.

Name | Description | |
---|---|---|
![]() | CircuitNamingSchemeId | The CircuitNamingSchemeId used in the Electrical Equipment. The CircuitNamingSchemeId is used to retrieve the circuit naming scheme id of the Electrical Equipment. |
![]() | DistributionSystem | get or set the Distribution System for the Electrical Equipment. |
![]() | IsSwitchboard | The electrical equipment is a switchboard or not. This property returns true if the electrical equipment is a switchboard. |
![]() | MaxNumberOfCircuits | The maximum number of circuits for switchboard. The quantity of circuits can be assigned to switchboard through breaker. |

Name | Description | |
---|---|---|
![]() | GetCircuitNamingSchemeType | Gets enumerated type of the circuit naming scheme used with Electrical Equipment. |
![]() ![]() | IsValidCircuitNamingSchemeId | Verifies that the circuit naming scheme id can be used with Electrical Equipment. |
![]() | IsValidDistributionSystem | Verifies that the Distribution System can be assigned to the Electrical Equipment. |
![]() | SetCircuitNamingSchemeType | Sets the circuit naming scheme for Electrical Equipment. |