GetFamilyTypeParameterValues Method


Family Get Family Type Parameter Values Method

Returns all applicable values for a FamilyType parameter of this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ISet<ElementId> GetFamilyTypeParameterValues(
	ElementId parameterId
)

Parameters

parameterId ElementId
A valid Id of a FamilyType parameter defined for this family.

Return Value

ISet ElementId
Ids of all applicable ElementType and NestedFamilyTypeReference elements.
Exceptions
Exception Condition
ArgumentException The given parameterId does not represent a valid FamilyType parameter of this family.
ArgumentNullException A non-optional argument was null
Remarks

The values are Element Ids of all family types that match the category specified by the definition of the given parameter. The elements are either of class ElementType or NestedFamilyTypeReference . The second variant is for the types that are nested in families and thus are not accessible otherwise.

If there are no applicable types of such category the returned collection will be empty.

See Also