VertexPositionNormalColored Class


Vertex Position Normal Colored Class

A geometry vertex specified as a position in space with a normal vector and a color.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D Vertex
Autodesk.Revit.DB.DirectContext3D VertexPositionNormalColored

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexPositionNormalColored : Vertex

The VertexPositionNormalColored type exposes the following members.

Constructors
Name Description
Public method VertexPositionNormalColored Constructs the vertex from a point, a normal vector, and a color.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Vertex )
Public property Normal The vertex's normal vector.
Public property Position The vertex's position.
Top
Methods
Name Description
Public method Dispose
(Inherited from Vertex )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetColor Gets the vertex's color.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetSizeInFloats Gets the amount of storage that the vertex takes up in a buffer, measured in floats.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetColor Sets the vertex's color.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The color of these vertices includes a transparency component In order to render them as transparent they must be rendered in the transparent pass See the 'IsTransparentPass' method of DrawContext
See Also