MoveElement Method


Element Transform Utils Move Element Method

Moves one element by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void MoveElement(
	Document document,
	ElementId elementToMove,
	XYZ translation
)

Parameters

document Document
The document that owns the elements.
elementToMove ElementId
The id of the element to move.
translation XYZ
The translation vector for the elements.
Exceptions
Exception Condition
ArgumentException The element elementToMove does not exist in the document
ArgumentNullException A non-optional argument was null
InvalidOperationException If we are not able to move the element (for example, if it is pinned). -or- Move operation failed.
See Also