ElectricalLoadAreaData Class


Electrical Load Area Data Class

Represents the electrical load area data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SpatialElementDomainData
Autodesk.Revit.DB.Electrical ElectricalLoadAreaData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalLoadAreaData : SpatialElementDomainData

The ElectricalLoadAreaData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from SpatialElementDomainData )
Top
Methods
Name Description
Public method Static member CreateElectricalLoadAreas Creates electrical load areas on all the empty plan circuits of the given level.
Public method Dispose
(Inherited from SpatialElementDomainData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAreaBasedLoadIds Gets the area based load ids of the electrical load area to be included.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member HasCircuitsWithoutElectricalLoadAreas Checks whether there are any empty plan circuits in which there are no electrical load areas.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also