ElectricalLoadAreaData Class


Electrical Load Area Data Class

Represents the electrical load area data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SpatialElementDomainData
Autodesk.Revit.DB.Electrical ElectricalLoadAreaData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalLoadAreaData : SpatialElementDomainData

The ElectricalLoadAreaData type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method Static member CreateElectricalLoadAreas Creates electrical load areas on all the empty plan circuits of the given level.
Public method GetAreaBasedLoadIds Gets the area based load ids of the electrical load area to be included.
Public method Static member HasCircuitsWithoutElectricalLoadAreas Checks whether there are any empty plan circuits in which there are no electrical load areas.
Top
See Also