IsOpen Method


Curve Loop Is Open Method

Returns whether the curve loop is open or closed, as determined by an internal flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsOpen()

Return Value

Boolean
True if the CurveLoop is marked open, false if marked closed.
Remarks
Some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.
See Also