ACADExportOptions Class


ACADExport Options Class

The base class for options used to export DWG and DXF format files.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ACADExportOptions : BaseExportOptions

The ACADExportOptions type exposes the following members.

Properties
Name Description
Public property ACAPreference The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property ExportingAreas True to export area and room geometry, false otherwise. Default value is false.
Public property ExportOfSolids The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property FileVersion ACADVersion::Default Default value is ACADVersion.Default.
Public property HatchBackgroundColor The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white
Public property LineScaling The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property LinetypesFileName The custom linetype file name (*.lin). Default value is empty.
Public property MarkNonplotLayers If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property NonplotSuffix If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property SharedCoords True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property TargetUnit The target unit type. Default value is ExportUnit.Default.
Public property TextTreatment The text treatment. Deault value is TextTreatment.Exact.
Public property UseHatchBackgroundColor Indicates if hatch background color will be used or not. default value is false.
Top
Methods
Name Description
Top
See Also