GetMaximum Method


Spatial Field Manager Get Maximum Method

Calculates the maximum value for all primitives

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetMaximum(
	int resultIndex,
	bool rawValue
)

Parameters

resultIndex Int32
Index of result schema
rawValue Boolean
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS

Return Value

Double
Resulting maximum value
Exceptions
Exception Condition
InapplicableDataException Thrown when current measurement is >= the number of measurements for at least one primitive
See Also