Structural |
Creates a new instance of Angle shape.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public StructuralSectionGeneralW(
double width,
double height,
double flangeThickness,
double webThickness,
double webFillet,
double flangeFillet,
double topWebFillet,
double centroidHorizontal,
double centroidVertical,
StructuralSectionAnalysisParams analysisParams
)
Parameters
- width Double
- Section width.
- height Double
- Section height, depth.
- flangeThickness Double
- Flange Thickness.
- webThickness Double
- Web Thickness.
- webFillet Double
- Web Fillet - fillet radius between web and flange.
- flangeFillet Double
- Flange Fillet - fillet radius at the flange end.
- topWebFillet Double
- Top Web Fillet - fillet radius at the top of web.
- centroidHorizontal Double
- Distance from centroid to the left extremites along horizontal axis.
- centroidVertical Double
- Distance from centroid to the upper extremites along vertical axis.
- analysisParams StructuralSectionAnalysisParams
- Common set of parameters for structural analysis.