LayerModifier Class


Layer Modifier Class

A modifier used to designate extra strings to appear in the exported layer name.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LayerModifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LayerModifier : IDisposable

The LayerModifier type exposes the following members.

Constructors
Name Description
Public method LayerModifier Constructs a new LayerModifier with default values.
Public method LayerModifier(ModifierType, String) Constructs a new LayerModifier with modifierType and separator.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ModifierType The modifier type of LayerModifier.
Public property Separator The separator string that will follow this modifier in the export layer name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LayerModifier
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A modifier consists of a type (from ModifierType and an optional separator. Apply a modifier to one or more ExportLayerInfo objects to modify the layer name that will be assigned when a Revit object is exported.
See Also