CADLink |
Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- options CADLinkOptions
- Options for reloading the link. Options include the ability to preserve graphic overrides on reload.
Return Value
LinkLoadResultAn object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document. |

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.