IsValidCategoryForEmbeddedSchedule Method


Schedule Definition Is Valid Category For Embedded Schedule Method

Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidCategoryForEmbeddedSchedule(
	ElementId categoryId
)

Parameters

categoryId ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for an embedded ScheduleDefinition, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also