GetLiningIds Method


Insulation Lining Base Get Lining Ids Method

Returns the ids of the lining elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetLiningIds(
	Document document,
	ElementId elemId
)

Parameters

document Document
The document.
elemId ElementId
The element.

Return Value

ICollection ElementId
A collection of the ids of the lining elements.
Exceptions
Exception Condition
ArgumentException This id does not represent a duct, fitting, or accessory element.
ArgumentNullException A non-optional argument was null
See Also