IIFCEntityTreeUIServer Interface


IIFCEntity Tree UIServer Interface

The interface used to provide UI on IFC Entity selection.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IIFCEntityTreeUIServer : IExternalServer

The IIFCEntityTreeUIServer type exposes the following members.

Methods
Name Description
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method ShowDialog Shows dialog on managing IFCEntityTreeUI.
Top
See Also