BuiltInFailures.PointFailures Class


Built In Failures Point Failures Class

Failures about Point Element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures PointFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class PointFailures

The BuiltInFailures PointFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotMakePointHostedByIntersection Cannot make point hosted by intersection.
Public property Static member CantChangeParamFlip Can't flip Element.
Public property Static member CantChangeParamMirror Can't mirror Element.
Public property Static member CantChangeParamRotate Can't rotate Element.
Public property Static member EdgeHostedPointToBeUnhosted A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
Public property Static member HostMeasurementError Invalid host curve measurement type or value or justification
Public property Static member HostParameterRangeError Hosted Parameter must be between 0 and 1
Public property Static member RegenFailure Regeneration Failure.
Top
See Also