FirstElementId Method


Filtered Element Collector First Element Id Method

Returns the id of the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId FirstElementId()

Return Value

ElementId
The first element id.
Exceptions
Exception Condition
InvalidOperationException The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also