Create Method


Fabrication Part Type Create Method

Creates a fabrication part type element based on a specific fabrication servic button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricationPartType Create(
	Document document,
	FabricationServiceButton button,
	int condition
)

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button.
condition Int32
The condition index.

Return Value

FabricationPartType
The created fabrication part type element.
Exceptions
Exception Condition
ArgumentException Fabrication service button contains invalid fittings.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The index condition is not larger or equal to 0 and less than ConditionCount.
InvalidOperationException The fabrication part type already exists.
See Also