IsLightOn Method


Light Group Manager Is Light On Method

Returns true if the given light is on for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsLightOn(
	ElementId viewId,
	ElementId lightId
)

Parameters

viewId ElementId
The Id of the view
lightId ElementId
The Id of the light

Return Value

Boolean
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
ArgumentNullException A non-optional argument was null
See Also