NewType Method


Family Manager New Type Method

Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FamilyType NewType(
	string typeName
)

Parameters

typeName String
The name of new family type.

Return Value

FamilyType
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"typeName"-is .
ArgumentException Thrown when the input argument-"typeName"-is already in use.
InvalidOperationException Thrown when the family type creation failed.
See Also