NewProjectDocument Method (UnitSystem)


Application New Project Document(Unit System) Method

Creates a new project document with no template file specified.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Document NewProjectDocument(
	UnitSystem unitSystem
)

Parameters

unitSystem UnitSystem
The unit system used for the new document.

Return Value

Document
The newly created document.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also