WireMaterialTypeSet Class


Wire Material Type Set Class

A set that contains wire material types.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical WireMaterialTypeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireMaterialTypeSet : APIObject, 
	IEnumerable

The WireMaterialTypeSet type exposes the following members.

Constructors
Name Description
Public method WireMaterialTypeSet Initializes a new instance of the WireMaterialTypeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of wire material types that are in the set.
Top
Methods
Name Description
Public method Clear Removes every wire material type from the set, rendering it empty.
Public method Contains Tests for the existence of a wire material type within the set.
Public method Erase Removes a specified wire material type from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified wire material type into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also