StairsComponentConnectionEndType Enumeration


Stairs Component Connection End Type Enumeration

The end type identifying the connection type among stairs runs and landings.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum StairsComponentConnectionEndType
Members
Member name Value Description
ET_Landing 0 A connection to the boundary of a stairs landing.
ET_RunEnd 2 A connection to the end (upper end) of a stairs run.
ET_RunStart 1 A connection to the start (lower end) of a stairs run.
See Also