Curve Project Method |
Projects the specified point on this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- point XYZ
- The point to be projected.
Return Value
IntersectionResultGeometric information if projection is successful.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when the curve is an arc and either its radius is zero or the input point is the center of the arc. Thrown when the curve is an elliptical arc and the input point is one of the foci of the elliptical arc. |

The following is the meaning of every IntersectionResult's members:
- XYZPoint is the nearest point on the curve;
- Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
- Distance is the distance from the point to the curve (equivalent to Distance).