Failures |
Checks if the transaction for which failures are processed is being committed or rolled back.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
BooleanTrue if current transaction is being committed, false if the transaction is being rolled back.

Exception | Condition |
---|---|
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |

A transaction is considered as "being committed" if a caller has requested the transaction to be committed and no previous failure processing operation requested the transaction to be rolled back.