SaveOptions Class


Save Options Class

This class contains options available for saving a document to disk.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SaveOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SaveOptions : IDisposable

The SaveOptions type exposes the following members.

Constructors
Name Description
Public method SaveOptions Default constructor.
Top
Properties
Name Description
Public property Compact Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PreviewViewId The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SaveOptions
Top
See Also