Family |
Creates a new angular dimension object using the specified dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Dimension NewAngularDimension(
View view,
Arc arc,
Reference firstRef,
Reference secondRef,
DimensionType dimensionType
)
Parameters
- view View
- The view in which the dimension is to be visible.
- arc Arc
- The extension arc of the dimension.
- firstRef Reference
- The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- secondRef Reference
- The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
DimensionIf creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when any input argument is . |
ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid. |
InvalidOperationException | Thrown when the creation failed. |