ExportImage Method


Document Export Image Method

Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ExportImage(
	ImageExportOptions options
)

Parameters

options ImageExportOptions
The options which govern the image export.
Exceptions
Exception Condition
ArgumentException The current view cannot be exported as an image
ArgumentNullException A non-optional argument was null
FileAccessException The path indicated could not be accessed.
FileNotFoundException The path indicated could not be found.
InvalidOperationException Exporting is not allowed in the current application mode. -or- Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
OptionalFunctionalityNotAvailableException The Graphics module is not available in the installed Revit.
See Also