Element |
A base class for filters used to match elements which intersect with geometry.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementIntersectsFilter
Autodesk.Revit.DB ElementIntersectsElementFilter
Autodesk.Revit.DB ElementIntersectsSolidFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementIntersectsFilter
Autodesk.Revit.DB ElementIntersectsElementFilter
Autodesk.Revit.DB ElementIntersectsSolidFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementIntersectsFilter type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() ![]() | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters. |
![]() ![]() | IsElementSupported | Identifies if the input element is supported by element intersection filters. |