GetAvailableParameterCategories Method


Table View Get Available Parameter Categories Method

Get all available parameter categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> GetAvailableParameterCategories(
	SectionType sectionType,
	int row
)

Parameters

sectionType SectionType
The section the row lies in.
row Int32
The row.

Return Value

IList ElementId
The available parameter categories.
Exceptions
Exception Condition
ArgumentException The sectionType is not a valid type for this view.
ArgumentOutOfRangeException The given row number row is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also