Extrusion
|

Autodesk.Revit.DB ExtrusionAnalyzer
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The ExtrusionAnalyzer type exposes the following members.

Name | Description | |
---|---|---|
![]() |
EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis. |
![]() |
ExtrusionDirection | The direction of extrusion specified for the extrusion analysis. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis. |

Name | Description | |
---|---|---|
![]() |
CalculateFaceAlignment | Calculates the alignment status of each face of the solid. |
![]() ![]() |
Create | Creates an ExtrusionAnalyzer and computes and stores the Solid's shadow. |
![]() |
Dispose | Releases all resources used by the ExtrusionAnalyzer |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

An instance of this class is a single-time use class which should be provided a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the Solid onto the input plane and along the extrusion direction.
After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.
This utility works best for a Solid that is at least somewhat "extrusion-like", for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.
The ExtrusionAnalyzer expects only one single extrusion-like solid geometry. The ExtrusionAnalyzer does not support a Solid containing multiple distinguishable "lumps" of geometry and may give unexpected results in such cases. In such cases, consider splitting the Solid into its individual connected commponent using [!:Autodesk::Revit::DB::SolidUtils::SplitVolumes] before performing an extrusion analysis.