Field |
Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- guid Guid
- The GUID of the subschema.
Return Value
FieldBuilderThe FieldBuilder object may be used to add more details to the field.

Exception | Condition |
---|---|
InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize SubSchemas. |

Fields of type Entity - subentities - need to specify their Schema. The framework will prevent subentities with incorrect schemas from being stored in the entity. Additionally, the access level of the subschema will be checked against the currently executing add-in and access to restricted subentities will be prevented.