Surface Class


Surface Class

A mathematical representation of a surface.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Surface
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Surface : IDisposable

The Surface type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OrientationMatchesParametricOrientation Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the Surface
Public method GetBoundingBoxUV Gets the UV bounding box of the surface.
Public method Project Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method ProjectWithGuessPoint Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Top
Remarks
This geometric object is not bounded by edges or edge loops. A bounded surface obtained from a Revit element will be represented by a Face instead.
See Also
Inheritance Hierarchy