IFCExternalServiceUIData Class


IFCExternal Service UIData Class

UI data wrapper for IFCExternalServiceUIData.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI IFCExternalServiceUIData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCExternalServiceUIData : IDisposable

The IFCExternalServiceUIData type exposes the following members.

Properties
Name Description
Public property Document return the document
Public property IsReset flag to indicate the value has been reset
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ParamId the parameter id
Public property SelectedIFCItem The selected IFC Item (can be IFC Entity, or PredefinedType)
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCExternalServiceUIData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParentHwnd return the parent handle
Public method GetRevitElementIds return the list of revit Element Ids
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also