UnitTypeId Class


Unit Type Id Class

This class contains constants identifying units of measurement.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB UnitTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class UnitTypeId

The UnitTypeId type exposes the following members.

Properties
Name Description
Public property Static member Acres Acres.
Public property Static member Amperes Amperes.
Public property Static member Atmospheres Atmospheres.
Public property Static member Bars Bars.
Public property Static member BritishThermalUnits British thermal units.
Public property Static member BritishThermalUnitsPerDegreeFahrenheit British thermal units per degree Fahrenheit.
Public property Static member BritishThermalUnitsPerHour British thermal units per hour.
Public property Static member BritishThermalUnitsPerHourCubicFoot British thermal units per hour cubic foot.
Public property Static member BritishThermalUnitsPerHourFootDegreeFahrenheit British thermal units per hour foot degree Fahrenheit.
Public property Static member BritishThermalUnitsPerHourSquareFoot British thermal units per hour square foot.
Public property Static member BritishThermalUnitsPerHourSquareFootDegreeFahrenheit British thermal units per hour square foot degree Fahrenheit.
Public property Static member BritishThermalUnitsPerPound British thermal units per pound.
Public property Static member BritishThermalUnitsPerPoundDegreeFahrenheit British thermal units per pound degree Fahrenheit.
Public property Static member BritishThermalUnitsPerSecond British thermal units per second.
Public property Static member BritishThermalUnitsPerSquareFootDegreeFahrenheit British thermal units per square foot degree Fahrenheit.
Public property Static member Calories Calories.
Public property Static member CaloriesPerSecond Calories per second.
Public property Static member Candelas Candelas.
Public property Static member CandelasPerSquareFoot Candelas per square foot.
Public property Static member CandelasPerSquareMeter Candelas per square meter.
Public property Static member Celsius Celsius.
Public property Static member CelsiusInterval Celsius interval.
Public property Static member Centimeters Centimeters.
Public property Static member CentimetersPerMinute Centimeters per minute.
Public property Static member CentimetersToTheFourthPower Centimeters to the fourth power.
Public property Static member CentimetersToTheSixthPower Centimeters to the sixth power.
Public property Static member Centipoises Centipoises.
Public property Static member CubicCentimeters Cubic centimeters.
Public property Static member CubicFeet Cubic feet.
Public property Static member CubicFeetPerHour Cubic feet per hour.
Public property Static member CubicFeetPerKip Cubic feet per kip.
Public property Static member CubicFeetPerMinute Cubic feet per minute.
Public property Static member CubicFeetPerMinuteCubicFoot Cubic feet per minute cubic foot.
Public property Static member CubicFeetPerMinutePerBritishThermalUnitPerHour Cubic feet per minute per British thermal unit per hour.
Public property Static member CubicFeetPerMinuteSquareFoot Cubic feet per minute square foot.
Public property Static member CubicFeetPerMinuteTonOfRefrigeration Cubic feet per minute ton of refrigeration.
Public property Static member CubicFeetPerPoundMass Cubic feet per pound mass.
Public property Static member CubicInches Cubic inches.
Public property Static member CubicMeters Cubic meters.
Public property Static member CubicMetersPerHour Cubic meters per hour.
Public property Static member CubicMetersPerHourCubicMeter Cubic meters per hour cubic meter.
Public property Static member CubicMetersPerHourSquareMeter Cubic meters per hour square meter.
Public property Static member CubicMetersPerKilogram Cubic meters per kilogram.
Public property Static member CubicMetersPerKilonewton Cubic meters per kilonewton.
Public property Static member CubicMetersPerSecond Cubic meters per second.
Public property Static member CubicMetersPerWattSecond Cubic meters per watt second.
Public property Static member CubicMillimeters Cubic millimeters.
Public property Static member CubicYards Cubic yards.
Public property Static member Currency Currency.
Public property Static member CurrencyPerBritishThermalUnit Cost per British thermal unit.
Public property Static member CurrencyPerBritishThermalUnitPerHour Cost per British thermal unit per hour.
Public property Static member CurrencyPerSquareFoot Cost per square foot.
Public property Static member CurrencyPerSquareMeter Cost per square meter.
Public property Static member CurrencyPerWatt Cost per watt.
Public property Static member CurrencyPerWattHour Cost per watt hour.
Public property Static member Custom Unrecognized custom unit.
Public property Static member CyclesPerSecond Cycles per second.
Public property Static member Decimeters Decimeters.
Public property Static member Degrees Degrees.
Public property Static member DegreesMinutes Degrees minutes seconds.
Public property Static member DekanewtonMeters Dekanewton meters.
Public property Static member DekanewtonMetersPerMeter Dekanewton meters per meter.
Public property Static member Dekanewtons Dekanewtons.
Public property Static member DekanewtonsPerMeter Dekanewtons per meter.
Public property Static member DekanewtonsPerSquareMeter Dekanewtons per square meter.
Public property Static member Fahrenheit Fahrenheit.
Public property Static member FahrenheitInterval Fahrenheit interval.
Public property Static member Feet Feet.
Public property Static member FeetFractionalInches Feet and fractional inches.
Public property Static member FeetOfWater39_2DegreesFahrenheit Feet of water (39.2 °F).
Public property Static member FeetOfWater39_2DegreesFahrenheitPer100Feet Feet of water (39.2 °F) per 100 feet.
Public property Static member FeetPerKip Feet per kip.
Public property Static member FeetPerMinute Feet per minute.
Public property Static member FeetPerSecond Feet per second.
Public property Static member FeetPerSecondSquared Feet per second squared.
Public property Static member FeetToTheFourthPower Feet to the fourth power.
Public property Static member FeetToTheSixthPower Feet to the sixth power.
Public property Static member Fixed Fixed.
Public property Static member Footcandles Footcandles.
Public property Static member Footlamberts Footlamberts.
Public property Static member FractionalInches Fractional inches.
Public property Static member General General.
Public property Static member Gigajoules Gigajoules.
Public property Static member Gradians Gradians.
Public property Static member GrainsPerHourSquareFootInchMercury Grains per hour square foot inch mercury.
Public property Static member Hectares Hectares.
Public property Static member Hertz Hertz.
Public property Static member Horsepower Horsepower.
Public property Static member Hours Hours.
Public property Static member HourSquareFootDegreesFahrenheitPerBritishThermalUnit Hour square foot degrees Fahrenheit per British thermal unit.
Public property Static member Inches Inches.
Public property Static member InchesOfMercury32DegreesFahrenheit Inches of mercury (32 °F).
Public property Static member InchesOfWater60DegreesFahrenheit Inches of water (60 °F).
Public property Static member InchesOfWater60DegreesFahrenheitPer100Feet Inches of water (60 °F) per 100 feet.
Public property Static member InchesPerSecondSquared Inches per second squared.
Public property Static member InchesToTheFourthPower Inches to the fourth power.
Public property Static member InchesToTheSixthPower Inches to the sixth power.
Public property Static member InverseDegreesCelsius Inverse degrees Celsius.
Public property Static member InverseDegreesFahrenheit Inverse degrees Fahrenheit.
Public property Static member InverseKilonewtons Inverse kilonewtons.
Public property Static member InverseKips Inverse kips.
Public property Static member Joules Joules.
Public property Static member JoulesPerGram Joules per gram.
Public property Static member JoulesPerGramDegreeCelsius Joules per gram degree Celsius.
Public property Static member JoulesPerKelvin Joules per Kelvin.
Public property Static member JoulesPerKilogramDegreeCelsius Joules per kilogram degree Celsius.
Public property Static member JoulesPerSquareMeterKelvin Joules per square meter Kelvin.
Public property Static member Kelvin Kelvin.
Public property Static member KelvinInterval Kelvin interval.
Public property Static member Kiloamperes Kiloamperes.
Public property Static member Kilocalories Kilocalories.
Public property Static member KilocaloriesPerSecond Kilocalories per second.
Public property Static member KilogramForceMeters Kilogram force meters.
Public property Static member KilogramForceMetersPerMeter Kilogram force meters per meter.
Public property Static member Kilograms Kilograms.
Public property Static member KilogramsForce Kilograms force.
Public property Static member KilogramsForcePerMeter Kilograms force per meter.
Public property Static member KilogramsForcePerSquareMeter Kilograms force per square meter.
Public property Static member KilogramsPerCubicMeter Kilograms per cubic meter.
Public property Static member KilogramsPerHour Kilograms per hour.
Public property Static member KilogramsPerKilogramKelvin Kilograms per kilogram kelvin.
Public property Static member KilogramsPerMeter Kilograms per meter.
Public property Static member KilogramsPerMeterHour Kilograms per meter hour.
Public property Static member KilogramsPerMeterSecond Kilograms per meter second.
Public property Static member KilogramsPerMinute Kilograms per minute.
Public property Static member KilogramsPerSecond Kilograms per second.
Public property Static member KilogramsPerSquareMeter Kilograms per square meter.
Public property Static member Kilojoules Kilojoules.
Public property Static member KilojoulesPerKelvin Kilojoules per Kelvin.
Public property Static member KilojoulesPerSquareMeterKelvin Kilojoules per square meter Kelvin.
Public property Static member KilometersPerHour Kilometers per hour.
Public property Static member KilometersPerSecondSquared Kilometers per second squared.
Public property Static member KilonewtonMeters Kilonewton meters.
Public property Static member KilonewtonMetersPerDegree Kilonewton meters per degree.
Public property Static member KilonewtonMetersPerDegreePerMeter Kilonewton meters per degree per meter.
Public property Static member KilonewtonMetersPerMeter Kilonewton meters per meter.
Public property Static member Kilonewtons Kilonewtons.
Public property Static member KilonewtonsPerCubicMeter Kilonewtons per cubic meter.
Public property Static member KilonewtonsPerMeter Kilonewtons per meter.
Public property Static member KilonewtonsPerSquareCentimeter Kilonewtons per square centimeter.
Public property Static member KilonewtonsPerSquareMeter Kilonewtons per square meter.
Public property Static member KilonewtonsPerSquareMillimeter Kilonewtons per square millimeter.
Public property Static member Kilopascals Kilopascals.
Public property Static member KilovoltAmperes Kilovolt amperes.
Public property Static member Kilovolts Kilovolts.
Public property Static member KilowattHours Kilowatt hours.
Public property Static member Kilowatts Kilowatts.
Public property Static member KipFeet Kip feet.
Public property Static member KipFeetPerDegree Kip feet per degree.
Public property Static member KipFeetPerDegreePerFoot Kip feet per degree per foot.
Public property Static member KipFeetPerFoot Kip feet per foot.
Public property Static member Kips Kips.
Public property Static member KipsPerCubicFoot Kips per cubic foot.
Public property Static member KipsPerCubicInch Kips per cubic inch.
Public property Static member KipsPerFoot Kips per foot.
Public property Static member KipsPerInch Kips per inch.
Public property Static member KipsPerSquareFoot Kips per square foot.
Public property Static member KipsPerSquareInch Kips per square inch.
Public property Static member Liters Liters.
Public property Static member LitersPerHour Liters per hour.
Public property Static member LitersPerMinute Liters per minute.
Public property Static member LitersPerSecond Liters per second.
Public property Static member LitersPerSecondCubicMeter Liters per second cubic meter.
Public property Static member LitersPerSecondKilowatt Liters per second kilowatt.
Public property Static member LitersPerSecondSquareMeter Liters per second square meter.
Public property Static member Lumens Lumens.
Public property Static member LumensPerWatt Lumens per watt.
Public property Static member Lux Lux.
Public property Static member Megajoules Megajoules.
Public property Static member MeganewtonMeters Meganewton meters.
Public property Static member MeganewtonMetersPerMeter Meganewton meters per meter.
Public property Static member Meganewtons Meganewtons.
Public property Static member MeganewtonsPerMeter Meganewtons per meter.
Public property Static member MeganewtonsPerSquareMeter Meganewtons per square meter.
Public property Static member Megapascals Megapascals.
Public property Static member Megawatts Megawatts.
Public property Static member Meters Meters.
Public property Static member MetersCentimeters Meters and centimeters.
Public property Static member MetersOfWaterColumn Meters of water column.
Public property Static member MetersOfWaterColumnPerMeter Meters of water column per meter.
Public property Static member MetersPerKilonewton Meters per kilonewton.
Public property Static member MetersPerSecond Meters per second.
Public property Static member MetersPerSecondSquared Meters per second squared.
Public property Static member MetersToTheFourthPower Meters to the fourth power.
Public property Static member MetersToTheSixthPower Meters to the sixth power.
Public property Static member MicroinchesPerInchDegreeFahrenheit Microinches per inch degree Fahrenheit.
Public property Static member MicrometersPerMeterDegreeCelsius Micrometers per meter degree Celsius.
Public property Static member MilesPerHour Miles per hour.
Public property Static member MilesPerSecondSquared Miles per second squared.
Public property Static member Milliamperes Milliamperes.
Public property Static member Millimeters Millimeters.
Public property Static member MillimetersOfMercury Millimeters of mercury.
Public property Static member MillimetersOfWaterColumn Millimeters of water column.
Public property Static member MillimetersOfWaterColumnPerMeter Millimeters of water column per meter.
Public property Static member MillimetersToTheFourthPower Millimeters to the fourth power.
Public property Static member MillimetersToTheSixthPower Millimeters to the sixth power.
Public property Static member MillionBritishThermalUnits Million British thermal units.
Public property Static member Milliseconds Milliseconds.
Public property Static member Millivolts Millivolts.
Public property Static member Minutes Minutes.
Public property Static member NanogramsPerPascalSecondSquareMeter Nanograms per pascal second square meter.
Public property Static member NewtonMeters Newton meters.
Public property Static member NewtonMetersPerMeter Newton meters per meter.
Public property Static member Newtons Newtons.
Public property Static member NewtonSecondsPerSquareMeter Newton seconds per square meter.
Public property Static member NewtonsPerMeter Newtons per meter.
Public property Static member NewtonsPerSquareMeter Newtons per square meter.
Public property Static member NewtonsPerSquareMillimeter Newtons per square millimeter.
Public property Static member OhmMeters Ohm meters.
Public property Static member OneToRatio 1 : Ratio.
Public property Static member Pascals Pascals.
Public property Static member PascalSeconds Pascal seconds.
Public property Static member PascalsPerMeter Pascals per meter.
Public property Static member Percentage Percentage.
Public property Static member PerMille Per mille.
Public property Static member Pi Multiples of π.
Public property Static member PoundForceFeet Pound force feet.
Public property Static member PoundForceFeetPerFoot Pound force feet per foot.
Public property Static member PoundForceSecondsPerSquareFoot Pound force seconds per square foot.
Public property Static member PoundsForce Pounds force.
Public property Static member PoundsForcePerCubicFoot Pounds force per cubic foot.
Public property Static member PoundsForcePerFoot Pounds force per foot.
Public property Static member PoundsForcePerSquareFoot Pounds force per square foot.
Public property Static member PoundsForcePerSquareInch Pounds force per square inch.
Public property Static member PoundsMass Pounds mass.
Public property Static member PoundsMassPerCubicFoot Pounds mass per cubic foot.
Public property Static member PoundsMassPerCubicInch Pounds mass per cubic inch.
Public property Static member PoundsMassPerFoot Pounds mass per foot.
Public property Static member PoundsMassPerFootHour Pounds mass per foot hour.
Public property Static member PoundsMassPerFootSecond Pounds mass per foot second.
Public property Static member PoundsMassPerHour Pounds mass per hour.
Public property Static member PoundsMassPerMinute Pounds mass per minute.
Public property Static member PoundsMassPerPoundDegreeFahrenheit Pounds mass per pound degree Fahrenheit.
Public property Static member PoundsMassPerSecond Pounds mass per second.
Public property Static member PoundsMassPerSquareFoot Pounds mass per square foot.
Public property Static member Radians Radians.
Public property Static member RadiansPerSecond Radians per second.
Public property Static member Rankine Rankine.
Public property Static member RankineInterval Rankine interval.
Public property Static member RatioTo1 Ratio : 1.
Public property Static member RatioTo10 Ratio : 10.
Public property Static member RatioTo12 Ratio : 12.
Public property Static member RevolutionsPerMinute Revolutions per minute.
Public property Static member RevolutionsPerSecond Revolutions per second.
Public property Static member RiseDividedBy1000Millimeters Rise / 1000 millimeters.
Public property Static member RiseDividedBy10Feet Rise / 10 feet.
Public property Static member RiseDividedBy120Inches Rise / 120 inches.
Public property Static member RiseDividedBy12Inches Rise / 12 inches.
Public property Static member RiseDividedBy1Foot Rise / 1 foot.
Public property Static member Seconds Seconds.
Public property Static member Shaku Shaku.
Public property Static member SlopeDegrees Degrees.
Public property Static member SquareCentimeters Square centimeters.
Public property Static member SquareCentimetersPerMeter Square centimeters per meter.
Public property Static member SquareFeet Square feet.
Public property Static member SquareFeetPer1000BritishThermalUnitsPerHour Square feet per thousand British thermal units per hour.
Public property Static member SquareFeetPerFoot Square feet per foot.
Public property Static member SquareFeetPerKip Square feet per kip.
Public property Static member SquareFeetPerSecond Square feet per second.
Public property Static member SquareFeetPerTonOfRefrigeration Square feet per ton of refrigeration.
Public property Static member SquareInches Square inches.
Public property Static member SquareInchesPerFoot Square inches per foot.
Public property Static member SquareMeterKelvinsPerWatt Square meter kelvins per watt.
Public property Static member SquareMeters Square meters.
Public property Static member SquareMetersPerKilonewton Square meters per kilonewton.
Public property Static member SquareMetersPerKilowatt Square meters per kilowatt.
Public property Static member SquareMetersPerMeter Square meters per meter.
Public property Static member SquareMetersPerSecond Square meters per second.
Public property Static member SquareMillimeters Square millimeters.
Public property Static member SquareMillimetersPerMeter Square millimeters per meter.
Public property Static member StationingFeet Feet.
Public property Static member StationingMeters Meters.
Public property Static member StationingSurveyFeet US survey feet.
Public property Static member Steradians Steradians.
Public property Static member Therms Therms.
Public property Static member ThousandBritishThermalUnits Thousand British thermal units.
Public property Static member ThousandBritishThermalUnitsPerHour Thousand British thermal units per hour.
Public property Static member TonneForceMeters Tonne force meters.
Public property Static member TonneForceMetersPerMeter Tonne force meters per meter.
Public property Static member Tonnes Tonnes.
Public property Static member TonnesForce Tonnes force.
Public property Static member TonnesForcePerMeter Tonnes force per meter.
Public property Static member TonnesForcePerSquareMeter Tonnes force per square meter.
Public property Static member TonsOfRefrigeration Tons of refrigeration.
Public property Static member UsGallons US gallons.
Public property Static member UsGallonsPerHour US gallons per hour.
Public property Static member UsGallonsPerMinute US gallons per minute.
Public property Static member UsSurveyFeet US survey feet.
Public property Static member UsTonnesForce US tonnes force.
Public property Static member UsTonnesMass US tonnes mass.
Public property Static member VoltAmperes Volt amperes.
Public property Static member VoltAmperesPerSquareFoot Volt amperes per square foot.
Public property Static member VoltAmperesPerSquareMeter Volt amperes per square meter.
Public property Static member Volts Volts.
Public property Static member Watts Watts.
Public property Static member WattsPerCubicFoot Watts per cubic foot.
Public property Static member WattsPerCubicFootPerMinute Watts per cubic foot per minute.
Public property Static member WattsPerCubicMeter Watts per cubic meter.
Public property Static member WattsPerCubicMeterPerSecond Watts per cubic meter per second.
Public property Static member WattsPerFoot Watts per foot.
Public property Static member WattsPerMeter Watts per meter.
Public property Static member WattsPerMeterKelvin Watts per meter kelvin.
Public property Static member WattsPerSquareFoot Watts per square foot.
Public property Static member WattsPerSquareMeter Watts per square meter.
Public property Static member WattsPerSquareMeterKelvin Watts per square meter kelvin.
Top
See Also