SetSubscriptStatus Method (TextRange, Boolean)


Formatted Text Set Subscript Status(Text Range, Boolean) Method

Sets the characters in a given text range to be subscript or not subscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSubscriptStatus(
	TextRange textRange,
	bool isSubscript
)

Parameters

textRange TextRange
The given text range.
isSubscript Boolean
The desired subscript status of characters in the given text range. True to set subscript, false to set not subscript.
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks

Superscript and subscript are mutually exclusive. Applying the subscript status will automatically remove the superscript status.

The given text range should not be empty.

See Also