ConnectAndCouple Method


Fabrication Part Connect And Couple Method

Makes a connection between the specified connectors and adds coupling if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ConnectAndCouple(
	Document document,
	Connector connector,
	Connector toConnector
)

Parameters

document Document
The document.
connector Connector
The connector of the fabrication part.
toConnector Connector
The connector of the fabrication part or family to connect to.

Return Value

Boolean
True if connection succeeded, false otherwise.
Exceptions
Exception Condition
ArgumentException The connector does not belong to a fabrication part. -or- The fabrication part connectors are not aligned, call AlignPartByConnectors to align them.
ArgumentNullException A non-optional argument was null
Remarks
This function does not place and align the fabrication part. Call AlignPartByConnectors before connecting.
See Also