BuiltInFailures.LoadFailures Class


Built In Failures Load Failures Class

Failures about Load.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures LoadFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class LoadFailures

The BuiltInFailures LoadFailures type exposes the following members.

Properties
Name Description
Public property Static member AreaLoadNotOverlappingHost Area load is not overlapping with its entire distribution its host.
Public property Static member CannotCopyHostedLoad Can't copy Load based on the Host Element.
Public property Static member CannotMirrorHostedLoad Can't mirror Load based on the Host Element.
Public property Static member CannotMirrorLoad Can't mirror Load because mirror plane is not perpendicular to sketch plane.
Public property Static member CannotMoveHostedLoad Can't move Load based on the Host Element.
Public property Static member CannotRotateLoad Can't rotate Load because rotation axis is not perpendicular to sketch plane.
Public property Static member InvalidAreaLoadSketchError Area Load has invalid Sketch.
Public property Static member LineLoadAllZero Line Load can't have all force components and moment components to be zero.
Public property Static member LineLoadNotOverlappingHost Line load is not overlapping with its entire distribution its host.
Public property Static member OpenAreaLoadLoopError Area Load Sketch can't contain open loops.
Public property Static member PointLoadAllZero Point Load can't have all force components and moment components to be zero.
Public property Static member PointLoadNotOverlappingHost Point load is not overlapping with its entire distribution its host.
Top
See Also