ReferenceArray Class


Reference Array Class

An array that contains reference objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ReferenceArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReferenceArray : APIObject, 
	IEnumerable

The ReferenceArray type exposes the following members.

Constructors
Name Description
Public method ReferenceArray Initializes a new instance of the ReferenceArray class
Top
Properties
Name Description
Public property IsEmpty Test to see if the array is empty.
Public property Item Gets or sets a reference at a specified index within the array.
Public property Size Returns the number of references that are in the array.
Top
Methods
Name Description
Public method Append Add the reference to the end of the array.
Public method Clear Removes every reference from the array, rendering it empty.
Public method ForwardIterator Retrieve a forward moving iterator to the array.
Public method GetEnumerator Retrieve a forward moving iterator to the array.
Public method Insert Insert the specified reference into the array.
Public method ReverseIterator Retrieve a backward moving iterator to the array.
Top
See Also