IsValidGeometry Method


Direct Shape Is Valid Geometry Method

Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidGeometry(
	Solid Geom
)

Parameters

Geom Solid
GeometryObject to be validated.

Return Value

Boolean
True if the supplied GeometryObject passes the validation criteria.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also