ImportIFCOptions Class


Import IFCOptions Class

Provides access to settings that control linking and opening IFC files.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ImportIFCOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ImportIFCOptions : IDisposable

The ImportIFCOptions type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LinkProcessor Specifies the engine to use while doing a Link IFC operation.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ImportIFCOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetImportIFCOptions Returns the current Revit instance's ImportIFCOptions.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.
See Also