Stairs |
Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static StairsPath Create(
Document document,
LinkElementId stairsId,
ElementId typeId,
ElementId planViewId
)
Parameters
- document Document
- The document.
- stairsId LinkElementId
- The id of the stairs element either in the host document or in a linked document.
- typeId ElementId
- The type of stairs path.
- planViewId ElementId
- The plan view in which the stairs path will be shown.
Return Value
StairsPathThe new stairs path.

Exception | Condition |
---|---|
ArgumentException | The stairsId is not a valid stairs. -or- The typeId is not a valid stairs path type. -or- The planViewId is not a valid plan view. -or- The stairsId already has a stairs path. -or- The stairsId is not visible in planViewId. |
ArgumentNullException | A non-optional argument was null |