ExportCategory Property


Energy Data Settings Export Category Property

Value is a category indicating which discipline model will be used for GreenBuildingXML export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId ExportCategory { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The export category is neither OST_Rooms nor OST_MEPSpaces.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
OST_Rooms will use the architectural 3d rooms for export. OST_MEPSpaces will use the MEP 3d Spaces for export.
See Also