GetClipPlanes Method


Draw Context Get Clip Planes Method

Gets the clipping planes for the Revit view where rendering takes place. Clipping planes control the 3D extent of a view and can be set using Section Box in Revit.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ClipPlane> GetClipPlanes()

Return Value

IList ClipPlane
The array of clipping planes, which is empty if none are set.
Exceptions
Exception Condition
InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also