AddAttachment Method


Wall Add Attachment Method

Attaches the wall to the target. If an attachment already exists with the same "attachmentLocation" value, an exception is thrown. The target should be a roof, floor, ceiling, toposolid, or other wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddAttachment(
	ElementId targetId,
	AttachmentLocation attachmentLocation
)

Parameters

targetId ElementId
Target element id.
attachmentLocation AttachmentLocation
The attachment location.
Exceptions
Exception Condition
ArgumentException -or- wall already has an attachment to targetId.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also