Spatial |
Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.

System Object
Autodesk.Revit.DB SpatialElementGeometryCalculator
Autodesk.Revit.DB SpatialElementGeometryCalculator
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The SpatialElementGeometryCalculator type exposes the following members.

Name | Description | |
---|---|---|
![]() | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements. |
![]() | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information. |
![]() ![]() | CanCalculateGeometry | This indicates whether the input spatial element is a valid one. |
![]() | Dispose | Releases all resources used by the SpatialElementGeometryCalculator |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetOptions | The options that control the calculation. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This class maintains an internal cache for geometry it has already processed. If you intend to calculate geometry for several elements in the same project you should use a single instance of this class. Note that the cache will be cleared when any change is made to the document.